Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #32 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 6 years ago

problem configuring generic source tarball under debian lenny: editline is missing

Reported by: aycan.irican@… Owned by: duncan
Priority: minor Milestone: 2009.2.0.1
Component: Generic source tarball Keywords: debian source editline
Cc:

Description

aycan@mon:~/haskell-platform-2009.2.0$ ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for ghc... /home/local/bin/ghc
checking for ghc-pkg... /home/local/bin/ghc-pkg
checking for hsc2hs... /home/local/bin/hsc2hs
checking version of ghc... 6.10.2
checking version of ghc-pkg matches... yes
checking ghc actually works... yes
checking the ghc core packages are all installed... no
configure: error: The core package editline-0.2.1.0 is missing. It should have been distributed with 6.10.2
aycan@mon:~/haskell-platform-2009.2.0$ ghci
GHCi, version 6.10.2: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer ... linking ... done.
Loading package base ... linking ... done.
Prelude> :q

Change History

  Changed 6 years ago by dons

  • milestone set to 2009.2.1

Strange. editline is listed as being available in ghc6 on Debian:

http://packages.debian.org/sid/amd64/ghc6/filelist

I wonder if this should be a bug against Debian, rather than the package? (We don't want to collect distro bugs here).

  Changed 6 years ago by duncan

That is strange indeed. We should get an explanation from the Debian folks.

From first impressions I'd say that the ghc installation should indeed have that core package registered and that the ./configure script has correctly discovered a problem.

  Changed 6 years ago by dons

Issue reported to the Debian Haskell team:

http://lists.debian.org/debian-haskell/2009/05/threads.html

  Changed 6 years ago by nomeata@…

Note that the snippet above mentions ghc-6.10.2, which is not packaged for Debian yet. Aycan must have gotten it somewhere else...

  Changed 6 years ago by jgoerzen@…

Smells as if the builder didn't install libeditline-dev or libedit-dev prior to building.

  Changed 6 years ago by dons

  • status changed from new to closed
  • resolution set to wontfix

OK. Closing. Not a bug with the platform, or Debian's packages.

My guess: wrong GHC+editline config downloads from haskell.org/ghc

follow-up: ↓ 8   Changed 6 years ago by aycan.irican@…

  • priority changed from blocker to minor
  • type changed from defect to enhancement

why we need editline package to build haskell platform?

in reply to: ↑ 7   Changed 6 years ago by duncan

Replying to aycan.irican@core.gen.tr:

why we need editline package to build haskell platform?

If you're asking which other platform packages need editline then the answer is none. If you're asking why do we look for editline, it's because the platform specifies a GHC release and the core libs that come with that release.

That said, we may need to make an exception anyway since I think GHC 6.10.3 does not include editline at all.

Note: See TracTickets for help on using tickets.