Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #35 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Haskell platform fails to compile under Mac OS X

Reported by: mvanier Owned by: dons
Priority: major Milestone: 2009.2.0
Component: Platform Keywords: Mac
Cc:

Description

The Haskell platform failed when I tried to compile it under Mac OS X Leopard. Configuration was fine, but "make" failed. The error line was:

Linking dist/build/happy/happy ... ld: in /Users/mvanier/_/src/haskell-platform/haskell-platform-2009.2.0/packages/mtl-1.1.0.2/dist/bui ld/libHSmtl-1.1.0.2.a, archive has no table of contents collect2: ld returned 1 exit status

Error: Building the happy-1.18.2 package failed make: *** [build.stamp] Error 2

I'm attaching a full log of output from "make".

Attachments

make.out (43.7 kB) - added by mvanier 6 years ago.

Change History

Changed 6 years ago by mvanier

Changed 6 years ago by RichardG

  • status changed from new to closed
  • resolution set to duplicate

This appears to be a duplicate of ticket:34.

Note: See TracTickets for help on using tickets.