Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:

Ticket #38 (closed enhancement: fixed)

Opened 7 years ago

Last modified 6 years ago

GLUT decide if this is API compat enough for 2009.2.1 upgrade

Reported by: dons Owned by: SvenPanne
Priority: major Milestone: 2009.2.0.1
Component: GLUT Keywords:
Cc: panne


The version of GLUT on hackage is newer than that shipped by the last release 2009.2.0.

  • Decide if the GLUT api has any breaking changes , or is minor-version compliant.
  • If version compliant, bump version supplied with 2009.2.1

Change History

Changed 7 years ago by panne

The GLUT package follows the PvP, so the current version is API compatible to the version shipped with 2009.2.0 (only API additions).

Changed 6 years ago by duncan

  • status changed from new to closed
  • resolution set to fixed

Libraries list policy decision was for minor releases to be patch-level only, no api additions. So we must postpone this update for the next major release.

Note: See TracTickets for help on using tickets.