Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #39 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

network 2.2.1.1: upgrade for 2009.2.1 ?

Reported by: dons Owned by: dons
Priority: major Milestone: 2009.2.0.1
Component: network Keywords:
Cc: tibbe

Description

The version of network on hackage is newer than that shipped by the last release 2009.2.0.

  • Decide if the network api has any breaking changes , or is minor-version compliant.
  • If version compliant, bump version supplied with 2009.2.1

Change History

follow-up: ↓ 2   Changed 5 years ago by tibbe

It's minor-version compliant (i.e. it follows the PVP). 2.2.1.1 was a bugfix release (see http://trac.haskell.org/network/ticket/8).

in reply to: ↑ 1   Changed 5 years ago by duncan

Replying to tibbe:

It's minor-version compliant (i.e. it follows the PVP). 2.2.1.1 was a bugfix release

Right, since network is following the PVP and it did not change the API at all (still API series 2.2.1.x) then it is fine to include in a minor platform release.

  Changed 5 years ago by dons

  • status changed from new to closed
  • resolution set to fixed

Resolved: network bumped to 2.2.1.1 in 2009.2.1

  Changed 5 years ago by tibbe

  • status changed from closed to reopened
  • resolution fixed deleted

2.2.1.2 has been release and fixes some Windows bugs. Do we want to include it in the next release?

  Changed 5 years ago by tibbe

  • owner changed from JohanTibell to dons
  • status changed from reopened to new

  Changed 5 years ago by tibbe

2.2.1.2 has a regression since 2.2.1.1 so we might want to stay with 2.2.1.1

http://trac.haskell.org/network/ticket/14

  Changed 5 years ago by duncan

  • status changed from new to closed
  • resolution set to fixed

Ok, sticking with 2.2.1.1.

Note: See TracTickets for help on using tickets.