Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #42 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Upgrade GHC 6.10.3 for 2009.2.1 release?

Reported by: dons Owned by: dons
Priority: blocker Milestone: 2009.2.0.1
Component: GHC Keywords: ghc
Cc:

Description (last modified by dons) (diff)

Does it make sense to upgrade to GHC 6.10.3 for the 2009.2.1 release?

Main issues:

  • what, if any, base libraries change? (editline is gone)
  • does that matter?

Change History

Changed 5 years ago by refold

+1 from me. What are the arguments against upgrading?

Changed 5 years ago by dons

  • description modified (diff)

Changed 5 years ago by anonymous

i vote for 6.10.3

reason: binary packages (such as gtk2hs on windows) will be probably built only against 6.10.3, so 6.10.2-based HP will be completely useless for me, dumb windows gtk2hs developer

Changed 5 years ago by duncan

I agree. We should move to GHC 6.10.3 for the next minor platform release (2009.2.1).

In general, minor platform release should be able to use updated minor releases of GHC. GHC is following a minor release policy that is (mostly) consistent with the minor release policy of the platform, ie just fixing bugs not adding new incompatible changes. There is some detail about compatible API additions but this policy can be worked out between the libs list and the GHC maintainers.

Changed 5 years ago by igloo

editline ought to be included as a standalone package, in that case.

Changed 5 years ago by dons

  • owner set to dons
  • component changed from (none-specified) to GHC

Changed 5 years ago by RichardG

6.10.3 support should be a top priority.

Users will be annoyed if 2009.2.1 doesn't support 6.10.3. New users and system admins who install but don't use will be the most affected and may get discouraged and/or develop a negative opinion. It's not the end of the world but it is a PR oops.

Can 2009.2.1 support both 6.10.2 and 6.10.3? 6.10.2 and 6.10.3 came out 1 month apart (very close together in GHC terms) and some people may not want to upgrade so quickly. (I upgraded to 6.10.2 a week before 6.10.3 was launched (then upgraded again right away.) If it's a hassle to make 2009.2.1 compatible with both versions of GHC, then make it compatible with 6.10.3 and keep 2009.2.0 available for download.

Changed 5 years ago by anonymous

I'd also like to see 6.10.3 included, primarily because not being able to control-c to kill 6.10.2 programs on Windows from a console window is a tad annoying.

Changed 5 years ago by dons

  • status changed from new to closed
  • resolution set to fixed

Ok. We move to 6.10.3.

Note: See TracTickets for help on using tickets.