Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #51 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

cabal is not able to install (at least) HXT on Windows

Reported by: azreal1977@… Owned by: dons
Priority: major Milestone: 2009.2.0.1
Component: Platform Keywords:
Cc:

Description

When I try: cabal install HXT it fails on libcurl saying "runGetProcess does not exist"

Change History

in reply to: ↑ description   Changed 6 years ago by anonymous

Replying to azreal1977@hotmail.com:

When I try: cabal install HXT it fails on libcurl saying "runGetProcess does not exist"

Oh, excuse me, it's "runGenProcess"

follow-up: ↓ 3   Changed 6 years ago by anonymous

This is not specific to the Haskell Platform installer. The problem is that curl uses a ./configure script. The ./configure scripts generally do not work on Windows unless you have mingw and MSYS installed and are running cabal install from within an MSYS shell.

However the error message is poor. The ticket for that is here: http://hackage.haskell.org/trac/hackage/ticket/403

in reply to: ↑ 2   Changed 6 years ago by anonymous

Replying to anonymous:

This is not specific to the Haskell Platform installer. The problem is that curl uses a ./configure script. The ./configure scripts generally do not work on Windows unless you have mingw and MSYS installed and are running cabal install from within an MSYS shell. However the error message is poor. The ticket for that is here: http://hackage.haskell.org/trac/hackage/ticket/403

Understood. My hope was simply that someone could build and include HXT or something in Haskell Platform so I can use it. :)

  Changed 6 years ago by dons

  • status changed from new to closed
  • resolution set to invalid
Note: See TracTickets for help on using tickets.