Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #55 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Mac OS X installer fails on OpenGL

Reported by: grady@… Owned by: gregorycollins
Priority: major Milestone: 2009.2.0.2
Component: OSX installer Keywords: OpenGL
Cc:

Description

During installation, I get the error: "The following install step failed: run postinstall script for OpenGL-2.2.1.1. Contact the software manufacturer for assistance."

% ghc --version The Glorious Glasgow Haskell Compilation System, version 6.10.3 % which ghc /opt/local/bin/ghc

Change History

Changed 6 years ago by dons

  • keywords OpenGL added
  • milestone set to 2009.2.0.2

Changed 6 years ago by dons

Missing OpenGL headers on the Mac? More detail needed, including a transcript of the configure phase.

Changed 6 years ago by dons

  • summary changed from installer fails on OpenGL to Mac OS X installer fails on OpenGL

Changed 6 years ago by duncan

What is the post-install script doing? Registering the package? What else? What makes us think it's missing headers that's the problem?

Changed 6 years ago by arnarbi@…

Here is the relevant part from my install log:

Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: Create temporary directory "/private/tmp/haskell-platform-2009.2.0.1-alpha2.pkg.854Y1FJXO"
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: Running install actions
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: Processing OpenGL-2.2.1.1:
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: 	Determining files to install
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: 	It took 0.03 seconds to create the install plan for OpenGL-2.2.1.1.
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: 	Configuring deferred files
Jun  3 23:26:28 arnar-birgissons-macbook Installer[854]: 	Determining obsolete files
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Assembling temporary receipt
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Performing pre-extraction actions
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Removing obsoleted files
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Creating destination path
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Validating package payload
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	Starting file extraction
Jun  3 23:26:29 arnar-birgissons-macbook payloadExtractor[861]: 	Initializing new flat-package receipt.
Jun  3 23:26:29 arnar-birgissons-macbook payloadExtractor[861]: 	Extracting...
Jun  3 23:26:29 arnar-birgissons-macbook payloadExtractor[861]: 	229 of 229 files written in 0.67 seconds.
Jun  3 23:26:29 arnar-birgissons-macbook payloadExtractor[861]: 	14460 kilobytes installed at 21.2 MB/s.
Jun  3 23:26:29 arnar-birgissons-macbook Installer[854]: 	run postupgrade script for OpenGL-2.2.1.1
Jun  3 23:26:30 arnar-birgissons-macbook /private/tmp/scripts.Hpex/./postflight[864]: Reading package info from stdin ... done.
Jun  3 23:26:30 arnar-birgissons-macbook /private/tmp/scripts.Hpex/./postflight[864]: ghc-pkg: dependency base-4.1.0.0 doesn't exist (use --force to override)
Jun  3 23:26:30 arnar-birgissons-macbook Installer[854]: Install failed: The following install step failed: run postupgrade script for OpenGL-2.2.1.1. Contact the software manufacturer for assistance.
Jun  3 23:26:30 arnar-birgissons-macbook Installer[854]: IFDInstallController 8AE170 state = 7
Jun  3 23:26:30 arnar-birgissons-macbook Installer[854]: Displaying 'Install Failed' UI.
Jun  3 23:26:30 arnar-birgissons-macbook Installer[854]: 'Install Failed' UI displayed message:'The following install step failed: run postupgrade script for OpenGL-2.2.1.1. Contact the software manufacturer for assistance.'.
Jun  3 23:26:36 arnar-birgissons-macbook installdb[860]: done. (0.030u + 0.025s)

Seems the error is on the 6th line from the bottom:

ghc-pkg: dependency base-4.1.0.0 doesn't exist (use --force to override)

Changed 6 years ago by arnarbi@…

I don't think it is the headers, I tried this:

cd /usr/include
sudo ln -s /System/Library/Frameworks/OpenGL.framework/Versions/A/Headers GL

which should put them where anyone can find them.

Changed 6 years ago by gregorycollins

Guys,

The GHC in /opt/local makes me think that this might be an issue re: an incompatibility between the MacPorts/Fink? version of GHC and the binary installer. I'd like to point out (if it wasn't clear) that this package is intended to be installed along with the official GHC binary distribution.

Changed 6 years ago by seabre

If you're having this problem, and you don't have fink/macports/whatever installed you probably don't have the latest version of GHC or have it at all. So, installing it will definitely fix your problem.

Changed 6 years ago by arnarbi@…

I was running a self-compiled version of GHC 6.10.1, which includes base 4.0.0.0. After installing the 6.10.3 binary package (which has base-4.1.0.0) everything works fine with the platform installer.

Changed 6 years ago by panne

Can we close this? Obviously it has nothing to do with the OpenGL package itself, but with the OS-X installer. I don't have a clue what a "postupgrade script" is, it is not part of the OpenGL package.

Changed 6 years ago by anonymous

Component: OSX Installer.

Greg Collins has the decision to close.

Changed 6 years ago by gregorycollins

  • status changed from new to closed
  • resolution set to invalid

Closing, this one is almost definitely an incompatibility between MacPorts/Fink? GHC and the OSX installer. Now that we're explicitly bundling them together the issue shouldn't appear.

If anyone is still seeing this with the "official" installer, please re-open.

Note: See TracTickets for help on using tickets.