Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #61 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

OSX installer fails

Reported by: practical.wisdom@… Owned by: gregorycollins
Priority: major Milestone:
Component: OSX installer Keywords:
Cc:

Description

This is not distinct from an earlier ticket, which I can't find. I didn't include the installer log with it, which might be of some use. The installer claims it can't find ghc-paths-0.1.0.5, but it is present in my present setup. yours Michael The last ten or so lines are these:

Jun 3 20:06:12 michael-thompsons-macbook payloadExtractor[767]: Initializing new flat-package receipt. Jun 3 20:06:12 michael-thompsons-macbook payloadExtractor[767]: Extracting... Jun 3 20:06:13 michael-thompsons-macbook payloadExtractor[767]: 47 of 47 files written in 0.83 seconds. Jun 3 20:06:13 michael-thompsons-macbook payloadExtractor[767]: 17740 kilobytes installed at 20.9 MB/s. Jun 3 20:06:13 michael-thompsons-macbook Installer[624]: run postupgrade script for haddock-2.4.2 Jun 3 20:06:13 michael-thompsons-macbook /private/tmp/scripts.pnOE/./postflight[770]: Reading package info from stdin ... done. Jun 3 20:06:13 michael-thompsons-macbook /private/tmp/scripts.pnOE/./postflight[770]: haddock-2.4.2: dependency ghc-paths-0.1.0.5 doesn't exist (use --force to override) Jun 3 20:06:13 michael-thompsons-macbook Installer[624]: Install failed: The following install step failed: run postupgrade script for haddock-2.4.2. Contact the software manufacturer for assistance. Jun 3 20:06:14 michael-thompsons-macbook Installer[624]: IFDInstallController 8AEDE0 state = 7 Jun 3 20:06:14 michael-thompsons-macbook Installer[624]: Displaying 'Install Failed' UI. Jun 3 20:06:14 michael-thompsons-macbook Installer[624]: 'Install Failed' UI displayed message:'The following install step failed: run postupgrade script for haddock-2.4.2. Contact the software manufacturer for assistance.'. Jun 3 20:06:20 michael-thompsons-macbook installdb[629]: done. (0.095u + 0.083s)

Attachments

osx.platform.fail.txt (39.7 kB) - added by Michael Thompson 6 years ago.
Installer log for OSX installer

Change History

Changed 6 years ago by Michael Thompson

Installer log for OSX installer

Changed 6 years ago by anonymous

  • status changed from new to closed
  • resolution set to duplicate

This is a dupe of #59, which was fixed by alpha 2.

Note: See TracTickets for help on using tickets.