Stop! Tickets are now managed at GitHub.

Please enter new tickets, and find and edit existing tickets there:


Ticket #83 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

HaskellPlatform-2009.2.0.2-setup.exe sets wrong PATH on Windows Vista 64

Reported by: anonymous Owned by: refold
Priority: minor Milestone:
Component: Windows installer Keywords:
Cc: the.dead.shall.rise@…

Description

what happens: The installer adds "C:\Program Files (x86)\Haskell\bin" to the PATH environment variable, a directory structure which is not created by the installer.

steps to reproduce: Run HaskellPlatform?-2009.2.0.2-setup.exe on Windows Vista 64, accept the default installation location, and let the installer adjust the PATH.

temporary fix: Adjust the PATH manually.

fix: Make the installer add "C:\Program Files (x86)\Haskell Platform\2009.2.0.2\bin" instead

Change History

follow-up: ↓ 3   Changed 5 years ago by refold

  • status changed from new to assigned

Actually, it should add both "$PROGRAMFILES\Haskell Platform\2009.2.0.2\bin" and "$PROGRAMFILES\Haskell\bin" to PATH, since the latter is where cabal-install puts executables. Are you sure that the former value isn't added?

  Changed 5 years ago by refold

  • cc the.dead.shall.rise@… added

in reply to: ↑ 1   Changed 5 years ago by anonymous

Replying to refold:

Actually, it should add both "$PROGRAMFILES\Haskell Platform\2009.2.0.2\bin" and "$PROGRAMFILES\Haskell\bin" to PATH, since the latter is where cabal-install puts executables. Are you sure that the former value isn't added?

Having checked the whole issue again, I find that everything is as it should be. I apologize for this waste of time, it was all a mistake on my part. Please close this ticket.

  Changed 5 years ago by refold

  • status changed from assigned to closed
  • resolution set to invalid
Note: See TracTickets for help on using tickets.