Changes between Version 3 and Version 4 of Proposals/async

Show
Ignore:
Timestamp:
06/13/12 13:49:03 (2 years ago)
Author:
simonmar (IP: 94.245.127.11)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Proposals/async

    v3 v4  
    7979 
    8080 * Perhaps there is a better name for `waitCatch` and friends? 
     81 * Is there a better name for `tryWait`?  (current name is by analogy with `tryTakeMVar`) 
    8182 * What should `waitAny` return? 
    8283 * Perhaps `waitAny` should work on any `Foldable`?