Ticket #18 (closed bug report: fixed)

Opened 5 years ago

Last modified 5 years ago

test machinery compiles with the wrong version

Reported by: nibro Owned by: greenrd
Priority: critical Milestone:
Component: other Version:
Keywords: Cc:

Description

The current Setup.hs doesn't compile, unless you already have a version of haskell-src-exts installed. The problem is that the module Test.Runner, imported by Setup, cannot find Language.Haskell.Exts since that resides in the src folder. Not sure how to make it find the module there.

I've pushed a quick patch to uncomment the test machinery from Setup until this can be fixed.

Change History

Changed 5 years ago by nibro

  • priority changed from blocker to critical
  • milestone Full code support deleted

Changed 5 years ago by nibro

  • status changed from new to closed
  • resolution set to fixed

Robin Green has kindly fixed this bug for 1.1.0. Case closed.

Note: See TracTickets for help on using tickets.