Ticket #204 (closed bug report: duplicate)

Opened 4 years ago

Last modified 4 years ago

Invalid parse for GADTs with strictness annotations

Reported by: NeilMitchell2 Owned by: nibro
Priority: major Milestone:
Component: parser Version: 1.8.x
Keywords: Cc:

Description

Given this file:

{-# LANGUAGE GADTs #-}
data Foo where Bar :: !Int -> Foo

GHC loads it fine, but HSE has a parse error:

$ ghci
GHCi, version 6.12.3: http://www.haskell.org/ghc/
Prelude> import Language.Haskell.Exts
Prelude Language.Haskell.Exts> parseFile "Temp.hs"
ParseFailed (SrcLoc {srcFilename = "Temp.hs", srcLine = 2, srcColumn = 23}) "Parse error: !"

For once, I ran into this when developing Hoogle, not HLint, although it would also show up there.

Change History

Changed 4 years ago by nibro

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #199

Note: See TracTickets for help on using tickets.