Ticket #57 (closed bug report: wontfix)

Opened 5 years ago

Last modified 5 years ago

Syntax error with qualified name in import hiding list

Reported by: Neil Mitchell Owned by: nibro
Priority: major Milestone: Blue Sky
Component: parser Version: 1.0.1
Keywords: Cc:

Description

The following code raises a parse error with HSE but is accepted by GHC:

module Main where
import Foo hiding (Bar.bar)
main = print "hlint"

The original bug report is at http://code.google.com/p/ndmitchell/issues/detail?id=200

I don't have any opinion on this feature, but since the source of the issue is in HSE it seems sensible for HLint to track the bug here. Perhaps the GHC developers need to be asked where this feature came from.

Change History

Changed 5 years ago by nibro

Just to note, I see no reason why the listed syntax should be allowed by any implementation. I can't see any reasonable use, and breaks the abstraction with regards to reexporting names from other modules. Unless the GHC people give a very good reason for its adoption, I would rather see this reported as a bug with GHC, for being too permissive.

Changed 5 years ago by nibro

  • milestone changed from Full document support to Blue Sky

Changed 5 years ago by nibro

  • status changed from new to closed
  • resolution set to wontfix

This has been branded a bug in GHC, and should no longer work in 6.21 (HEAD).

Note: See TracTickets for help on using tickets.