Ticket #7 (closed bug report: fixed)

Opened 5 years ago

Last modified 5 years ago

Parser still balks on some MPTC deriving

Reported by: nibro Owned by: nibro
Priority: major Milestone: Full code support
Component: parser Version:
Keywords: Cc:

Description

newtype SucParser s a = SucParser (S.StateT [s] [] a)
    deriving (Functor, A.Applicative, A.Alternative, M.Monad, M.MonadPlus, S.MonadState [s])

The problem is the [s]. I tried to be clever when implementing this since I figured the argument had to be a type variable or a type constructor. Clearly I need to generalize a bit further.

Change History

Changed 5 years ago by nibro

  • status changed from new to closed
  • resolution set to fixed

Generalization complete. We now allow any valid instance type as argument. Case closed.

Note: See TracTickets for help on using tickets.