Ticket #19 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

haskellmode-20100622.vba is malformatted

Reported by: byorgey Owned by: claus
Priority: critical Milestone:
Component: --- Version: latest (please provide version in text)
Keywords: Cc:

Description

Loading haskellmode-20100622.vba and doing :so % leads to a bunch of errors being spewed out. It appears that some comments were added in the haskell_hpaste section which invalidated the length of the section and causes the remainder of the file to be misparsed. Changing '79' to '81' fixes the problem.

Change History

Changed 4 years ago by haskellmode

Thanks for the report, but I cannot confirm the problem here (Windows, Vim 7.2). The number of lines recorded by vimball is always 2 less than the number of lines shown by Vim for the folded section (the length of the embedded content, without the header comment), so '79' looks correct, and extracting the vimball works without problem for me (the hpaste support hasn't changed for so long that it is unlikely still to function, but that shouldn't affect extraction: 79 lines in the previous vimball, 79 lines in this one).

We used to have problems with older vimballs not setting the fileformat to 'unix' (which works for extraction on both unix and windows machines) before writing the file, leading to issues with lineendings, but this one seems to be correct.

The plugins used to be tested on Windows and Unix, but I can only test on Windows at the moment, so I'd need some assistance in identifying platform-specific quirks interfering with haskellmode. Could you please provide some more info about the error messages?

Changed 4 years ago by haskellmode

  • status changed from new to closed
  • resolution set to invalid

Can't reproduce, and no info from submitter.

Note: See TracTickets for help on using tickets.