Ticket #22 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

GHCi can't show bangstars when the file is compiled.

Reported by: Masse Owned by: claus
Priority: major Milestone:
Component: compiler/ghc.vim Version:
Keywords: bang, omnifunc Cc:

Description

GHCi and ghc --interactive can't browse *Module if the file is compiled. This renders the omnifunc useless as the autocommand QuickFixCmdPost? runs GHC_BrowseAll after running make.

How to reproduce:

Run :GHCReload, import a new module, run :make and try to C_xC-o a function from the new imported module.

Expected behaviour:

The cache should be updated and C-xC-o should return a list of possible completions.

Real behaviour:

Cache isn't updated and the symbols aren't found.

Possible fix:

Instead of updating the cache with every :make, update it with every :w (see patch)

Change History

Changed 4 years ago by haskellmode

  • status changed from new to closed
  • resolution set to duplicate

duplicate of #21

Note: See TracTickets for help on using tickets.