Ticket #25 (new defect)

Opened 6 years ago

lhc doesn't build on windows

Reported by: ssylvan Owned by:
Priority: normal Milestone:
Component: unspecified Version:
Keywords: Cc:
Test Case:

Description

There seems to be some dependencies on unix packages. It's probably easier to get rid of them earlier rather than later?

cabal: Error: some packages failed to install: lhc-0.6.20090126 depends on unix-2.3.1.0 which failed to install. regex-compat-0.71.0.1 depends on regex-posix-0.72.0.3 which failed to install. regex-posix-0.72.0.3 failed during the configure step. The exception was: sh: runGenProcess: does not exist (No such file or directory) unix-2.3.1.0 failed during the configure step. The exception was: sh: runGenProcess: does not exist (No such file or directory)

Note: See TracTickets for help on using tickets.