Ticket #10 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Network.Socket.connect: support for sockets w/ bound local endpoints

Reported by: tibbe Owned by:
Priority: major Milestone:
Component: network Version:
Keywords: Cc: sof@…

Description

Just in case this isn't taken care of by the ongoing rewrite of 'network', but there's an age-old limitation in the implementation of Network.Socket.connect -- it balks at being given a socket where the local endpoint (port,iface) has already been bound.

i.e., it socket status test ought to be

not (currentStatus elem [NotConnected??,Bound])

The workaround of manually resetting SocketStatus?? always leaves me feeling icky.

(Copied from http://hackage.haskell.org/trac/ghc/ticket/3143)

Change History

Changed 5 years ago by bos

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of ticket #3.

Note: See TracTickets for help on using tickets.