Ticket #14 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Building 2.2.1.2 fails on Windows

Reported by: tibbe Owned by: bos
Priority: major Milestone: 2.2.1.3
Component: network Version:
Keywords: Cc: ndmitchell@…

Description

  • Windows XP Pro SP2
  • GHC 6.10.3
  • MinGW 5.1.4
  • msys 1.0
$ cabal build
Preprocessing library network-2.2.1.2...
In file included from Network\BSD.hsc:17:
include/HsNet.h:140: error: syntax error before "addr"
include/HsNet.h: In function `my_inet_ntoa':
include/HsNet.h:146: error: storage size of 'a' isn't known
include/HsNet.h:147: error: `addr' undeclared (first use in this function)
include/HsNet.h:147: error: (Each undeclared identifier is reported only once
include/HsNet.h:147: error: for each function it appears in.)
include/HsNet.h:148: warning: return makes pointer from integer without a cast
Network\BSD.hsc: In function `main':
Network\BSD.hsc:145: error: invalid application of `sizeof' to incomplete type `servent' 
Network\BSD.hsc:145: error: invalid application of `sizeof' to incomplete type `servent' 
Network\BSD.hsc:145: error: invalid application of `sizeof' to incomplete type `servent' 
Network\BSD.hsc:149: error: dereferencing pointer to incomplete type
Network\BSD.hsc:150: error: dereferencing pointer to incomplete type
Network\BSD.hsc:153: error: dereferencing pointer to incomplete type
Network\BSD.hsc:154: error: dereferencing pointer to incomplete type
Network\BSD.hsc:249: error: invalid application of `sizeof' to incomplete type `protoent' 
Network\BSD.hsc:249: error: invalid application of `sizeof' to incomplete type `protoent' 
Network\BSD.hsc:249: error: invalid application of `sizeof' to incomplete type `protoent' 
Network\BSD.hsc:253: error: dereferencing pointer to incomplete type
Network\BSD.hsc:254: error: dereferencing pointer to incomplete type
Network\BSD.hsc:261: error: dereferencing pointer to incomplete type
Network\BSD.hsc:339: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:339: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:339: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:343: error: dereferencing pointer to incomplete type
Network\BSD.hsc:344: error: dereferencing pointer to incomplete type
Network\BSD.hsc:347: error: dereferencing pointer to incomplete type
Network\BSD.hsc:349: error: dereferencing pointer to incomplete type
Network\BSD.hsc:448: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:448: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:448: error: invalid application of `sizeof' to incomplete type `hostent' 
Network\BSD.hsc:452: error: dereferencing pointer to incomplete type
Network\BSD.hsc:453: error: dereferencing pointer to incomplete type
Network\BSD.hsc:456: error: dereferencing pointer to incomplete type
Network\BSD.hsc:457: error: dereferencing pointer to incomplete type
compiling dist\build\Network\BSD_hsc_make.c failed
command was: c:\ghc\ghc-6.10.1\gcc.exe -c -Bc:\ghc\ghc-6.10.1\gcc-lib -Ic:\ghc\ghc-6.10.1\include\mingw -D__GLASGOW_HASKELL__=610 -Iinclude -DCALLCONV=stdcall -DBASE4 -Ic:\ghc\ghc-6.10.1\base-4.0.0.0\include -Ic:\ghc\ghc-6.10.1/include -IPAPI_INCLUDE_DIR dist\build\Network\BSD_hsc_make.c -o dist\build\Network\BSD_hsc_make.o

Change History

Changed 6 years ago by tibbe

This is a regression since 2.2.1.1

Changed 6 years ago by tibbe

  • owner set to bos

Bryan, this is probably related to one of your Windows patches. Do you mind taking a look?

Changed 6 years ago by tibbe

  • status changed from new to closed
  • resolution set to fixed

Head from darcs builds fine for me on above mentioned setup.

Changed 6 years ago by anonymous

So we're in good shape?

Note: See TracTickets for help on using tickets.