Ticket #24 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

errors with Network.URI on OS X

Reported by: mthompso Owned by:
Priority: minor Milestone: 2.2.1.6
Component: network Version:
Keywords: uri error Cc:

Description

I'm nor sure this is a valid defect, since it seems to happen for some people but not others. I am using Glasgow Haskell Compiler, Version 6.10.4 on Mac OS X 1.6 "Snow Leopard". But what I can see is the same difficulty came up for me before and came up on the Pandoc list, as Conal Elliot was having trouble with the installation of Pandoc with GHC 6.10.3 and OS X 1.5 "Leopard":

http://groups.google.com/group/pandoc-discuss/browse_thread/thread/7770b8c53a703acd/0d813562215298cb?lnk=gst&q=man#0d813562215298cb

or:

http://tinyurl.com/y8w3bbg

I had the same problem with the new Pandoc 1.3 which led me to investigate (and notice Conal E.'s note). It is that the last act of Pandoc's setup process uses pandoc to make its man pages out of Markdown versions. The problem is that (for some of us, under some conditions) two uri's that appear in the docs,

    <http://ctan.org>
    <http://johnmacfarlane.net/pandoc/> 

are sent to Network.URI for parsing, and it makes an error. If, for example, one of the slashes is omitted, things are fine.

I can verify this apart from Pandoc. If I import Network.URI and compile the micro-executable:

    main = getArgs >>= putStrLn . show . parseURIReference . head

as "uri", I get:

    $ ./uri hohohoh
    Just hohohoh
    $ ./uri http:no.com
    Just http:no.com
    $ ./uri http:/no.com
    Just http:/no.com
    $ ./uri http://no.com
    Bus error
    $ ./uri ftp://no.com
    Bus error
    $ ./uri http://www.google.com
    uri: : openFile: does not exist (No such file or directory)
    $ ./uri http:/www.google.com
    Just http:/www.google.com
    $ ./uri 1:/www.google.com
    Nothing
    $ ./uri 1://www.google.com
    Nothing

Like I said, it seems not everyone has this problem, otherwise no one could install Pandoc on OS X without doing an end-run around the manpages. It isn't the 32 v 64 bit business with Snow Leopard, I think, since it's clear that Elliott's "Bus Error" in his second note is the one above, and that the difficulty he was having in the first letter was the same as the one I have had repeatedly in the past year. The error message is sort of random, fooling around as above with the pandoc mandocs I got

    $ pandoc -s -r markdown -w man a.txt -o a.man
    Segmentation fault
    $ pandoc -s -r markdown -w man a.txt -o a.man
    Segmentation fault
    $ pandoc -s -r markdown -w rtf b.txt -o b.rtf
    Illegal instruction
    $ pandoc -s -r markdown -w rtf b.txt -o b.rtf
    Segmentation fault
    $ pandoc -s -r markdown -w rtf b.txt -o b.rtf
    Segmentation fault
    $ pandoc -s -r markdown -w rtf b.txt -o b.rtf
    Bus error

I hope this isn't a too-stupid ticket.

Change History

Changed 5 years ago by tibbe

  • status changed from new to closed
  • resolution set to worksforme
  • milestone set to 2.2.1.6

After an offline discussion we concluded that the problem isn't with network. Closing ticket.

Note: See TracTickets for help on using tickets.