Ticket #4 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

sIsReadable and sIsWritable return true after socket is closed.

Reported by: igloo Owned by:
Priority: major Milestone:
Component: network Version:
Keywords: Cc:

Description

First reported here: http://hackage.haskell.org/trac/ghc/ticket/2774


> import Network.Socket
> s <- socket AF_INET Stream 6
Loading package parsec-2.1.0.1 ... linking ... done.
Loading package network-2.2.0.1 ... linking ... done.
> bindSocket s (SockAddrInet 0 0)
> listen s 1
> sClose s
> sIsReadable s
True
> sIsWritable s
True

sIsReadable and sIsWritable return true when the SocketStatus is Connected or Listening. sClose does not change the status. Perhaps a new status Closed should be added to SocketStatus.

Change History

Changed 6 years ago by bos

  • status changed from new to closed
  • resolution set to duplicate

This is a duplicate of ticket #6, and is already fixed.

Note: See TracTickets for help on using tickets.