Ticket #14 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

gnome terminal displays non-basic attributes as strikethrough

Reported by: coconnor Owned by: coconnor
Priority: blocker Milestone:
Component: Uncategorized Version:
Keywords: Cc:

Description

The expectation is that gnome terminal will display non-default attributes as expected. Instead non-default attributes are displayed with a strikethrough.

Caused by the hard-coded xterm-ANSI terminal attribute codes.

Attachments

hleder-issue-14.png (153.3 kB) - added by coconnor 6 years ago.

Change History

Changed 6 years ago by coconnor

  • status changed from new to assigned

Changed 6 years ago by coconnor

Changed 6 years ago by coconnor

  • priority changed from major to blocker

Changed 5 years ago by coconnor

  • status changed from assigned to closed
  • resolution set to fixed

Resolved latest in darcs. Note: The latest in darcs is for vty version 4.0.0. Any programs currently dependent on vty 3 need to be updated to account for API changes in vty 4.

See patch attached to:

for an example conversion.

Note: See TracTickets for help on using tickets.