Opened 5 years ago

Closed 5 years ago

#10123 closed bug (invalid)

GHCi won't start in Powershell ISE

Reported by: qwfy Owned by:
Priority: normal Milestone:
Component: GHCi Version: 7.8.3
Keywords: powershell Cc: hvr
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: Incorrect result at runtime Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by qwfy)

To reproduce,

  1. Start Powershell ISE (Windows PowerShell ISE Host 4.0 on Windows 8.1)
  2. Type "ghci"

You will see the output:

GHCi, version 7.8.3: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer-gmp ... linking ... done.
Loading package base ... linking ... done.

After Loading package base ... linking ... done., GHCi just hangs, won't continue, the prompt is never displayed.

Change History (2)

comment:1 Changed 5 years ago by qwfy

Description: modified (diff)

comment:2 Changed 5 years ago by Phyx-

Resolution: invalid
Status: newclosed

This is not a bug with GHCi, Powershell ISE is not a real console, it's a GUI based emulation which does not support interactive console applications.

The same thing will happen if you try to run cmd /K

More details: http://blogs.msdn.com/b/powershell/archive/2009/02/04/console-application-non-support-in-the-ise.aspx

Note: See TracTickets for help on using tickets.