Opened 4 years ago

Closed 4 years ago

#10459 closed bug (worksforme)

-fsimple-tick-factor required

Reported by: mikehat Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.6.3
Keywords: fsimple-tick-factor Cc:
Operating System: Linux Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

ghc: panic! (the 'impossible' happened)
  (GHC version 7.6.3 for x86_64-unknown-linux):
	Simplifier ticks exhausted
    When trying UnfoldingDone base:Foreign.Storable.$fStorableWord8_$cpokeByteOff{v rsA} [gid]
    To increase the limit, use -fsimpl-tick-factor=N (default 100)
    If you need to do this, let GHC HQ know, and what factor you needed
    To see detailed counts use -ddump-simpl-stats
    Total ticks: 10400

-fsimple-tick-factor=115 was required

See the 'css' branch of https://github.com/mikehat/blaze-markup.git

Change History (5)

comment:1 Changed 4 years ago by Henk-Jan

I got almost the same message when compiling package SFML:

[34 of 72] Compiling SFML.Graphics.Transform ( dist\dist-sandbox-12e87adf\build\SFML\Graphics\Transform.hs, dist\dist-sandbox-12e87adf\build\SFML\Graphics\Transform.o ) ghc.exe: panic! (the 'impossible' happened)

(GHC version 7.10.1 for i386-unknown-mingw32):

Simplifier ticks exhausted

When trying UnfoldingDone $j_s8N2 To increase the limit, use -fsimpl-tick-factor=N (default 100) If you need to do this, let GHC HQ know, and what factor you needed To see detailed counts use -ddump-simpl-stats Total ticks: 380264

Setting -fsimpl-tick-factor=20000000 did not help. I am using GHC 7.10.1 on Windows.

comment:2 Changed 4 years ago by thomie

Edit: lets track the SFML issue from comment:1 in #10584.

Last edited 4 years ago by thomie (previous) (diff)

comment:3 Changed 4 years ago by thomie

mikehat: I tried for a while to reproduce your problem, but failed up to now. Can you please try again in a cabal sandbox, and provide the following information:

  • exact commands that result in failure (cabal build? cabal test?)
  • which commit
  • which versions of dependencies
  • cabal version

With the following settings I didn't have any problems running cabal build:

  • ghc-7.6.3
  • commit ea9ee861d77f4c65543de4e00a8188856ba4d994 without the -fsimpl-tick-factor=175 in the cabal file
  • these libraries installed: text-1.2.0.4 blaze-builder-0.3.3.4
  • cabal-install 1.22.2.0 Cabal-1.22.2.0

comment:4 Changed 4 years ago by thomie

Status: newinfoneeded

comment:5 Changed 4 years ago by thomie

Resolution: worksforme
Status: infoneededclosed

mikehat: as I said in comment:3, I can't reproduce your problem with ghc-7.6. Please reopen if this is still a problem for you.

Note: See TracTickets for help on using tickets.