Opened 4 years ago

Closed 4 years ago

#10530 closed bug (wontfix)

Update transformers library

Reported by: thoughtpolice Owned by:
Priority: normal Milestone: 7.10.2
Component: libraries (other) Version: 7.10.2-rc2
Keywords: transformers Cc: asr
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Other Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

As noted in a reply to the RC1 announcement, we should update transformers to the latest version (which merely adds some new instances for Const).

We should also do a once over for the other libraries.

Change History (10)

comment:1 Changed 4 years ago by thoughtpolice

Owner: set to thoughtpolice

comment:2 Changed 4 years ago by asr

Cc: asr added

comment:3 Changed 4 years ago by thoughtpolice

Resolution: wontfix
Status: newclosed

Actually, after talking about this with Simon etc, we're somewhat inclined to leave it out as we normally reserve point releases for bug fixes - and while transformers *was* updated, it only added a few instances, meaning that mostly what's affected are orphans out in the wild.

So I'm actually punting this out of 7.10.2, although if someone feels strongly, they can just re-open and we can consider it.

comment:4 Changed 4 years ago by asr

Owner: thoughtpolice deleted
Resolution: wontfix
Status: closednew

In Agda and GHC 7.8.*, we couldn't drop support for transformers-0.3.0.0 because transformers is a GHC-included package which makes it difficult for Agda distributions to upgrade. Now, with GHC 7.10.1 we have a similar problem with transformers-0.4.2.0.

I guess this is not a problem related only to Agda, so I'm reopening the ticket.

comment:5 Changed 4 years ago by rwbarton

What is the problem exactly? Are you in a huge hurry to drop support for transformers-0.4.2.0? The latest version of Agda on Hackage seems to support several GHC versions' worth of packages that come with GHC.

comment:6 in reply to:  5 Changed 4 years ago by asr

Replying to rwbarton:

What is the problem exactly? Are you in a huge hurry to drop support for transformers-0.4.2.0?

I reopened the ticket no because there is a problem right now, but I want to avoid a possible future problem.

Let's suppose Agda will use an instance only available in transformers-0.4.3.0 and let's suppose that a new version of the distribution X (for example, Ubuntu) will be shipped with GHC 7.10.2, which includes transformers-0.4.2.0. In consequence, or Agda will need to support both versions of transformers or the distribution X won't include Agda.

comment:7 Changed 4 years ago by thoughtpolice

Right, but as I said before, this release simply added instances - which I think is a minimal burden (via MIN_VERSION_transformers or whatnot). Of course, people are free to disagree.

If it was a bugfix release, I'd probably feel differently (indeed, binary underwent a bump for 7.10.2 precisely because it had 2 real bugfixes). But here I don't think a bump is really necessary for a minor orphan addition in this case.

comment:8 Changed 4 years ago by asr

I don't want to block the release of GHC 7.10.2 for this ticket, so I won't open the ticket again if you close it again.

An issue was reported in the Agda bug tracker yesterday (see Issue 1590). It seems the issue is related to a missing instance in transformers 0.3.0.0. This is exactly the class of problems I want to avoid.

Last edited 4 years ago by asr (previous) (diff)

comment:9 Changed 4 years ago by asr

Version: 7.10.2-rc17.10.2-rc2

comment:10 Changed 4 years ago by bgamari

Resolution: wontfix
Status: newclosed

We decided against this bump a few weeks ago. Closing.

Note: See TracTickets for help on using tickets.