Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#10669 closed bug (duplicate)

Missing Generic instances for base types.

Reported by: vagarenko Owned by:
Priority: normal Milestone:
Component: libraries/base Version: 7.10.1
Keywords: Generics Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

There is instance Generic Int in GHC.Generics, but no Generic Word.

Also there is no Generic instances for Int8, Int16, Int32, Int64, Word8, Word16, Word32, Word64.

Change History (2)

comment:1 Changed 4 years ago by rwbarton

Resolution: duplicate
Status: newclosed

Duplicate of #10512.

comment:2 Changed 3 years ago by RyanGlScott

Keywords: Generics added
Note: See TracTickets for help on using tickets.