Opened 4 years ago

Closed 3 years ago

#11703 closed bug (fixed)

Segmentation fault/internal error: evacuate: strange closure type 15 with GHC.Generics

Reported by: NathanWaivio Owned by:
Priority: normal Milestone:
Component: Runtime System Version: 7.10.3
Keywords: Segmentation Fault, Generics, Runtime error Cc: simonmar
Operating System: Unknown/Multiple Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case: attached
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Reproduced issue on both Windows-7/GHC-7.10.3 and Linux-4.1.15/GHC-7.8.4 Seems to probably be a problem with GHC.Generics and the runtime.

Windows/GHC-7.10.3 states: internal error: evacuate: strange closure type 15 (GHC version 7.10.3 for x86_64_unkown_mingw32) Please report this as a GHC bug: httpLwww.haskell.org/ghc/reportabug This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

Linux/GHC-7.8.4 states: Segmentation fault

Behavior varies based on CSV input file size, a CSV file with header with 1 to 4 rows works. A CSV with a header and more than 10 rows segmentation faults imediatly. Inbetween 4 to 10 sometimes runs forever, works, or segmentation faults.

The test case uses Cassava and GHC.Generics and some derived instances to read a CSV file with a record data type with many fields.

Attachments (3)

csv-test.hs (32.7 KB) - added by NathanWaivio 4 years ago.
Code that causes problem
test-passes.csv (9.1 KB) - added by NathanWaivio 4 years ago.
Input file that works
test-fails.csv (42.5 KB) - added by NathanWaivio 4 years ago.
Input file that fails

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by NathanWaivio

Attachment: csv-test.hs added

Code that causes problem

Changed 4 years ago by NathanWaivio

Attachment: test-passes.csv added

Input file that works

Changed 4 years ago by NathanWaivio

Attachment: test-fails.csv added

Input file that fails

comment:1 Changed 3 years ago by RyanGlScott

Interestingly, I can reproduce this on Linux x86_64 with GHC 7.10.3, but not with GHC 8.0.

comment:2 Changed 3 years ago by RyanGlScott

Resolution: fixed
Status: newclosed

I'm going to close this because (1) I can't reproduce it anymore, and (2) the example requires far too many dependencies to be a reliable test case.

Note: See TracTickets for help on using tickets.