Opened 3 years ago

Closed 3 years ago

#12123 closed bug (duplicate)

GHC crashes when calling typeRep on a promoted tuple

Reported by: MikeIzbicki Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.0.1
Keywords: Typeable Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The following code (asking for the typeRep of a promoted tuple) causes GHC to crash.

import Data.Typeable
import Data.Proxy

x = typeRep (Proxy::Proxy '(Int,Int))

The error message is:

[1 of 1] Compiling Main             ( ../Bug.hs, interpreted )
GHC error in desugarer lookup in Main:
  Can't find interface-file declaration for variable $tc'(,)
    Probable cause: bug in .hi-boot file, or inconsistent .hi file
    Use -ddump-if-trace to get an idea of which file caused the error
ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 8.1.20160518 for x86_64-unknown-linux):
        initDs IOEnv failure

Change History (2)

comment:1 Changed 3 years ago by simonpj

Keywords: Typeable added

comment:2 Changed 3 years ago by zilinc

Resolution: duplicate
Status: newclosed

seems to be a duplicate of #12132

Note: See TracTickets for help on using tickets.