Opened 2 years ago

Closed 2 years ago

#13540 closed task (duplicate)

Enable -msse2 by default on i386

Reported by: bgamari Owned by: bgamari
Priority: high Milestone: 8.4.1
Component: Compiler Version: 8.0.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #8949 Differential Rev(s):
Wiki Page:

Description

SSE2 has been around for nearly 15 years now and at this point it is supported nearly universally. Currently we pass -msse2 to numerically-sensitive testsuite tests since x87 is too imprecise.

Change History (5)

comment:1 Changed 2 years ago by bgamari

Owner: set to bgamari

comment:2 Changed 2 years ago by Ben Gamari <ben@…>

In e5e07be/ghc:

base: Run num009 with -msse2 on i386

x87's transcendental instructions are terribly imprecise and fail this test.
Moreover, we really ouch to enable -mse2 on i386 by default as it is nearly
universally supported at this point. See #13540.

comment:3 Changed 2 years ago by MikolajKonarski

comment:4 Changed 2 years ago by Phyx-

Just want to point out that neither the linux elf nor Windows GHCi linkers (non-dynamic way) currently honor section alignment. so using SSE2 more aggressively would likely cause issues here.

comment:5 Changed 2 years ago by bgamari

Resolution: duplicate
Status: newclosed

Indeed this is a duplicate of #8949.

Note: See TracTickets for help on using tickets.