Opened 2 years ago

Closed 18 months ago

#13690 closed bug (worksforme)

Running profiling tests in the GHCi way is extremely slow

Reported by: dfeuer Owned by:
Priority: normal Milestone: 8.6.1
Component: Compiler Version: 8.2.1-rc2
Keywords: Cc: dobenour
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Runtime performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Running, e.g., profinline001 in the GHCi way takes somewhere around eleven seconds. This seems pretty extreme. I noticed this when writing T12962 in the as-yet-unmerged Phab:D3550, which takes about the same amount of time. These are very small and very simple bits of code that don't do much at all, so it seems the problem must lie elsewhere. I have no idea where, though.

Change History (4)

comment:1 Changed 2 years ago by dfeuer

Reproduction:

Build GHC with BuildFlavour = perf. Change to the testsuite directory and run make TEST=profinline001. The compiled ways run in the blink of an eye, but the GHCi way (--interactive) takes around 11 seconds.

comment:2 Changed 2 years ago by dfeuer

Cc: dobenour added

bgamari thought dobenour might consider these good test cases for a potential bytecode interpreter rework.

comment:3 Changed 20 months ago by bgamari

Milestone: 8.4.18.6.1

This ticket won't be resolved in 8.4; remilestoning for 8.6. Do holler if you are affected by this or would otherwise like to work on it.

comment:4 Changed 18 months ago by bgamari

Resolution: worksforme
Status: newclosed

Hmm, I can't reproduce this. time make test TEST=profinline001 WAY=prof shows a real time of 300 milliseconds on my machine.

Note: See TracTickets for help on using tickets.