Opened 2 years ago

Closed 2 years ago

#13854 closed bug (duplicate)

the 'impossible' happened initTc: unsolved constraints

Reported by: bitemyapp Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.0.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time crash or panic Test Case:
Blocked By: Blocking:
Related Tickets: #13106 Differential Rev(s):
Wiki Page:

Description

[7 of 7] Compiling Texas.Api.OrderItems ( src/Texas/Api/OrderItems.hs, interpreted )
ghc: panic! (the 'impossible' happened)
  (GHC version 8.0.2 for x86_64-unknown-linux):
	initTc: unsolved constraints
  WC {wc_insol =
        [W] OrderItemModified_a1mbC :: t_a1mbB[tau:1] (CHoleCan: OrderItemModified)
        [W] val_a1mbH :: t_a1mbG[tau:1] (CHoleCan: val)
        [W] runAccountDB_a1md0 :: t_a1mcZ[tau:1] (CHoleCan: runAccountDB)
        [W] getOrderItemsByOrderId_a1mdb :: t_a1mda[tau:1] (CHoleCan: getOrderItemsByOrderId)}

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

I have what I believe is a repro of this error, albeit slightly different, located here: https://github.com/bitemyapp/panic-repro-initTc-unsolved-constraints

[3 of 3] Compiling Lib              ( src/Lib.hs, .stack-work/dist/x86_64-linux/Cabal-1.24.2.0/build/Lib.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 8.0.2 for x86_64-unknown-linux):
	initTc: unsolved constraints
  WC {wc_insol =
        [W] over_amEW :: t_amEV[tau:1] (CHoleCan: over)
        [W] ix_amF5 :: t_amF4[tau:1] (CHoleCan: ix)}

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

This is the error I get there. If I learn more in the process of fixing the original code, I'll report it here. This panic occurs w/ GHC and GHCi.

Change History (1)

comment:1 Changed 2 years ago by RyanGlScott

Resolution: duplicate
Status: newclosed

Thanks for the bug report. This is a duplicate of #13106, which has been fixed in GHC 8.2.

Note that this panic is usually caused by using identifiers that aren't in-scope (in your case, over and ix) in just the right way.

Note: See TracTickets for help on using tickets.