Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#13991 closed bug (duplicate)

I was building/testing a haskell project using stack ..suddenly I see the following output. Also attached the project

Reported by: chandrakoduru Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.0.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #13106 Differential Rev(s):
Wiki Page:

Description (last modified by RyanGlScott)

putting-haskell-to-test-0.0.1.0: build (lib + test)
Preprocessing library putting-haskell-to-test-0.0.1.0...
Preprocessing test suite 'HUnitTest' for putting-haskell-to-test-0.0.1.0...
[1 of 1] Compiling Main             ( test/HUnitTest/Spec.hs, .stack-work/dist/x86_64-linux/Cabal-1.24.2.0/build/HUnitTest/HUnitTest-tmp/Main.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 8.0.2 for x86_64-unknown-linux):
        initTc: unsolved constraints
  WC {wc_insol =
        [W] @?=_a1lM :: t_a1lL[tau:1] (CHoleCan: @?=)
        [W] testCase_a1m2 :: t_a1m1[tau:1] (CHoleCan: testCase)
        [W] simpleMathFunction_a1mb :: t_a1ma[tau:1] (CHoleCan: simpleMathFunction)
        [W] @?=_a1xp :: t_a1xo[tau:1] (CHoleCan: @?=)
        [W] testCase_a1xB :: t_a1xA[tau:1] (CHoleCan: testCase)
        [W] simpleMathFunction_a1xK :: t_a1xJ[tau:1] (CHoleCan: simpleMathFunction)}
             
Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
             
Progress: 1/2
--  While building package putting-haskell-to-test-0.0.1.0 using:
      /home/local/ANT/chandrak/.stack/setup-exe-cache/x86_64-linux/Cabal-simple_mPHDZzAJ_1.24.2.0_ghc-8.0.2 --builddir=.stack-work/dist/x86_64-linux/Cabal-1.24.2.0 build lib:putting-haskell-to-test test:HUnitTest --ghc-options " -ddump-hi -ddump-to-file"
    Process exited with code: ExitFailure 1

Attachments (1)

putting-haskell-to-test.zip (25.3 KB) - added by chandrakoduru 3 years ago.
zipped project directory

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by chandrakoduru

Attachment: putting-haskell-to-test.zip added

zipped project directory

comment:1 Changed 3 years ago by chandrakoduru

Forgot to mention..

I am on Ubuntu

4.4.0-83-generic x86_64

Distributor ID: Ubuntu

Description: Ubuntu 16.04.2 LTS

Release: 16.04

Codename: xenial

stack --version Version 1.4.0, Git revision e714f1dd3fade19496d91bd6a017e435a96a6bcd (4640 commits) x86_64 hpack-0.17.0

comment:2 Changed 3 years ago by chandrakoduru

Architecture: Unknown/Multiplex86_64 (amd64)
Operating System: Unknown/MultipleLinux
Type of failure: None/UnknownCompile-time crash or panic
Version: 8.0.18.0.2

comment:3 Changed 3 years ago by simonpj

Architecture: x86_64 (amd64)Unknown/Multiple
Operating System: LinuxUnknown/Multiple
Type of failure: Compile-time crash or panicNone/Unknown
Version: 8.0.28.0.1

Probably a dup of #13106. (There are many dups of this bug.) Can you try with a more recent GHC?

Last edited 3 years ago by simonpj (previous) (diff)

comment:4 Changed 3 years ago by RyanGlScott

Description: modified (diff)
Status: newinfoneeded

comment:5 Changed 2 years ago by RyanGlScott

Resolution: duplicate
Status: infoneededclosed

Closing as a probable dupe of #13106. Please re-open if you experience the same issue on GHC 8.2.1.

Last edited 2 years ago by RyanGlScott (previous) (diff)
Note: See TracTickets for help on using tickets.