Opened 2 years ago

Closed 14 months ago

#14294 closed bug (duplicate)

IndexError: pop from empty list

Reported by: heisenbug Owned by: bgamari
Priority: normal Milestone:
Component: Trac & Git Version: 8.2.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #10927 Differential Rev(s):
Wiki Page:

Description

How to Reproduce

While doing a GET operation on /attachment/ticket/14293/, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'action': u'new', 'path': u'14293/', 'realm': u'ticket'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/603.3.8 (KHTML, like Gecko) Version/10.1.2 Safari/603.3.8

System Information

Systeminformation nicht verfügbar

Enabled Plugins

Plugininformation nicht verfügbar

Interface Customization

Interface customization information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 623, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/main.py", line 259, in dispatch
    iterable=chrome.use_chunked_encoding)
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1165, in render_template
    encoding='utf-8')
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 184, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 350, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 829, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 669, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 774, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/usr/local/lib/python2.7/dist-packages/genshi/output.py", line 594, in __call__
    for ev in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1432, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/trac/web/chrome.py", line 1421, in _generate
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/transform.py", line 706, in _unmark
    for mark, event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/transform.py", line 1101, in __call__
    for mark, event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/transform.py", line 118, in __iter__
    event = self.stream.next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/transform.py", line 734, in __call__
    for mark, event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/transform.py", line 702, in _mark
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 362, in _match
    content = list(content)
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 326, in _match
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/core.py", line 289, in _ensure
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 618, in _include
    for event in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/markup.py", line 315, in _strip
    event = next()
  File "/usr/local/lib/python2.7/dist-packages/genshi/template/base.py", line 558, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 178, in _generate
    for event in msgbuf.translate(gettext(msgbuf.format())):
  File "/usr/local/lib/python2.7/dist-packages/genshi/filters/i18n.py", line 1051, in translate
    events = self.events[order].pop(0)
IndexError: pop from empty list

Change History (5)

comment:1 Changed 2 years ago by heisenbug

I wanted to add the test file as an attachment. It did not work :-( adding it here instead, if it works...

comment:2 Changed 2 years ago by bgamari

comment:3 Changed 2 years ago by heisenbug

Yes. But attaching to this ticket gave the same error.

comment:4 Changed 2 years ago by bgamari

Owner: set to bgamari

Alright, I'll need to look into this.

comment:5 Changed 14 months ago by thomie

Component: CompilerTrac & Git
Resolution: duplicate
Status: newclosed

This is a duplicate of #10927.

Note: See TracTickets for help on using tickets.