Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#14531 closed bug (duplicate)

tcIfaceGlobal (local): not found

Reported by: bigos Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.2.1
Keywords: hs-boot Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: #14382 Differential Rev(s):
Wiki Page:

Description (last modified by bigos)

I have installed Msys2 on Windows. In Msys2 I have installed Emacs, which I start with a custom cmd script with following environment variables set:

SET PATH=C:\msys64\mingw64\bin;C:\msys64\usr\bin;%PATH%

set XDG_DATA_DIRS=c:/msys64/mingw64/share
set PKG_CONFIG_PATH=c:/msys64/mingw64/lib/pkgconfig
set INCLUDE=c:/msys64/mingw64/include

The haskell I have is from Full Haskell Platform, https://haskell.org/platform/download/8.2.1/HaskellPlatform-8.2.1-full-x86_64-setup.exe

Then, within Emacs I have started eshell which I used to invoke this command:

cabal install gi-gtk

Which after a while gave me following error.

[91 of 95] Compiling GI.Pango.Objects.Layout ( GI\Pango\Objects\Layout.hs, dist\build\GI\Pango\Objects\Layout.o )
ghc.exe: panic! (the 'impossible' happened)
  (GHC version 8.2.1 for x86_64-unknown-mingw32):
	tcIfaceGlobal (local): not found
  You are in a maze of twisty little passages, all alike.
  While forcing the thunk for TyThing Layout
  which was lazily initialized by initIfaceCheck typecheckLoop,
  I tried to tie the knot, but I couldn't find Layout
  in the current type environment.
  If you are developing GHC, please read Note [Tying the knot]
  and Note [Type-checking inside the knot].
  Consider rebuilding GHC with profiling for a better stack trace.
  Contents of current type environment: []
  Call stack:
      CallStack (from HasCallStack):
        prettyCurrentCallStack, called at compiler\utils\Outputable.hs:1133:58 in ghc:Outputable
        callStackDoc, called at compiler\utils\Outputable.hs:1137:37 in ghc:Outputable
        pprPanic, called at compiler\iface\TcIface.hs:1696:23 in ghc:TcIface

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

cabal: Leaving directory 'C:\Users\Jacek\AppData\Local\Temp\cabal-tmp-8093\gi-pango-1.0.15'
Failed to install gi-gio-2.0.14
Build log ( C:\Users\Jacek\AppData\Roaming\cabal\logs\ghc-8.2.1\gi-gio-2.0.14-GKluzGq73QJBrHtRklhQDd.log ):
Preprocessing library for gi-gio-2.0.14..
Building library for gi-gio-2.0.14..

Change History (4)

comment:1 Changed 22 months ago by bigos

Description: modified (diff)

comment:2 Changed 22 months ago by Phyx-

Architecture: x86_64 (amd64)Unknown/Multiple
Keywords: Windows Msys2 removed
Operating System: WindowsUnknown/Multiple

Thanks for the report, this isn't Windows specific so I'm throwing it in the general pool.

comment:3 Changed 22 months ago by RyanGlScott

Resolution: duplicate
Status: newclosed

Thanks for the bug report. This is a duplicate of #14382, so I'll close this ticket in favor of that one.

comment:4 Changed 22 months ago by simonpj

Keywords: hs-boot added
Note: See TracTickets for help on using tickets.