#14857 closed bug (wontfix)

GHC-8.4.1 release notes don't mention 'Div', 'Mod' and other type families

Reported by: chshersh Owned by:
Priority: normal Milestone: 8.4.1
Component: Documentation Version: 8.4.1-alpha3
Keywords: base, documentation, div, mod, type families, changelog, release notes Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

GHC 8.4.1 brought support for Div, Mod and Log2 type families for type level natural numbers:

I'm actually using this feature in o-clock package

But I was told about this feature only by other Haskell developer. And I don't see this change described in release notes for GHC 8.4.1:

Change History (3)

comment:1 Changed 22 months ago by Phyx-

This seems to be a base rather than a compiler change, which means it's documented in the base changelog, https://github.com/ghc/ghc/blob/ghc-8.4/libraries/base/changelog.md

Though perhaps we should somehow link to this changelog. That said, we don't advertise changes by other boot packages unless they're really important, like backwards incompatible changes.

comment:2 Changed 22 months ago by chshersh

Thanks for your response! I just saw that base library in mentioned in GHC changelog and thought that every change in bundled libraries is documented there. I think that mentioning only most important changes and providing link to library changelog is the best solution!

comment:3 Changed 19 months ago by RyanGlScott

Resolution: wontfix
Status: newclosed

As mentioned above, this was by design, since this change wasn't deemed important enough to mention in the GHC release notes themselves. Closing.

Note: See TracTickets for help on using tickets.