#14992 closed bug (duplicate)

Allow existentials to UNPACK

Reported by: simonpj Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.2.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by simonpj)

Consider

data T a where
  MkT :: b -> (b->a) -> T a

data Wuggle where
  MkW :: {-# UNPACK #-} !T Int -> Wuggle

Here MkT has an existential, but there is really no reason that it can't unpack into the data constructor for MkW. But it is currently rejected.

Change History (1)

comment:1 Changed 19 months ago by simonpj

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Ugh. Duplicate of #10016

Note: See TracTickets for help on using tickets.