#15035 closed bug (duplicate)

Panic when using StaticPointers with typed holes

Reported by: utdemir Owned by:
Priority: normal Milestone: 8.6.1
Component: Compiler Version: 8.4.1
Keywords: StaticPointers, TypedHoles Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Compile-time crash or panic Test Case:
Blocked By: Blocking:
Related Tickets: #13499 Differential Rev(s):
Wiki Page:

Description

Adding a type hole when there is a type variable in StaticPtr throws a GHC panic:

{-# LANGUAGE StaticPointers #-}

module Foo where

import Data.Typeable
import GHC.StaticPtr

foo :: Typeable a => StaticPtr a
foo = static _ 
[1 of 1] Compiling Foo              ( test.hs, test.o )

test.hs:9:14: error:ghc: panic! (the 'impossible' happened)
  (GHC version 8.4.1 for x86_64-unknown-linux):
	No skolem info:
  [a_aD2[sk:2]]
  Call stack:
      CallStack (from HasCallStack):
        callStackDoc, called at compiler/utils/Outputable.hs:1150:37 in ghc:Outputable
        pprPanic, called at compiler/typecheck/TcErrors.hs:2945:5 in ghc:TcErrors

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

This panics on both GHC 8.2.2 and 8.4.1.

Change History (1)

comment:1 Changed 17 months ago by RyanGlScott

Keywords: StaticPointers TypedHoles added
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #13499.

Note: See TracTickets for help on using tickets.