Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#1601 closed bug (worksforme)

ghc-6.6.1: internal error: evacuate: strange closure type 7600

Reported by: guest Owned by:
Priority: normal Milestone: 6.8.1
Component: Compiler Version: 6.6.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

I tried to compile the Kaya compiler with GHC. GHC crashed with an internal error and told me to file a bug report:

...
[20 of 28] Compiling InfGadgets       ( InfGadgets.hs, InfGadgets.o )
[21 of 28] Compiling Inference        ( Inference.hs, Inference.o )
ghc-6.6.1: internal error: evacuate: strange closure type 7600
    (GHC version 6.6.1 for i386_unknown_linux)

My OS is Fedora Core 6, Kaya-Version is 0.2.6 You can reach me at oliver-at-firstfloor.org

Change History (6)

comment:1 Changed 12 years ago by igloo

Description: modified (diff)

comment:2 Changed 12 years ago by igloo

Milestone: 6.8

Kaya is here: http://kayalang.org/src/kaya-0.2.6.tgz

I can't reproduce the problem on amd64/Linux with GHC 6.6.1.

comment:3 Changed 12 years ago by simonmar

Resolution: worksforme
Status: newclosed

On my x86/Ubuntu box with GHC 6.6 I didn't manage to compile all of kaya, but I did get past the Haskell bit, so I guess I can't reproduce the bug either, at least with this setup.

This kind of error is often indicative of a hardware failure, so I'm closing it until/unless we can find a better repro case.

comment:4 Changed 12 years ago by igloo

Milestone: 6.8 branch6.8.1

comment:5 Changed 11 years ago by simonmar

Architecture: UnknownUnknown/Multiple

comment:6 Changed 11 years ago by simonmar

Operating System: UnknownUnknown/Multiple
Note: See TracTickets for help on using tickets.