Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#16071 closed bug (duplicate)

GHC is stuck (runs indefinitely) compiling a module

Reported by: dirtypaw Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.6.3
Keywords: Cc:
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: Building GHC failed Test Case:
Blocked By: Blocking:
Related Tickets: #16057 Differential Rev(s):
Wiki Page:

Description

Compiling Agda with ghc-8.6.3 using stack, ghc is stuck at this module (runs for 20+ min with no progress).

It looks like a regression in ghc-8.6.3 on Windows as Agda is successfully built with ghc-8.6.2 on the same machine, and Agda build with ghc-8.6.3 is generally supported (see this issue).

Change History (3)

comment:1 Changed 8 months ago by RyanGlScott

Resolution: duplicate
Status: newclosed

Thanks for the bug report. Given that that module uses Template Haskell splices, this is a duplicate of #16057, so I'll close this ticket in favor of that one.

comment:2 Changed 8 months ago by simonpj

#16057 seems Windows-specific. Is this ticket Windows-specific too?

comment:3 in reply to:  description Changed 8 months ago by RyanGlScott

To quote the ticket description:

It looks like a regression in ghc-8.6.3 on Windows

Note: See TracTickets for help on using tickets.