Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#16109 closed bug (duplicate)

cabal install H under Windows 10 does not terminate

Reported by: dsamperi Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.6.3
Keywords: Cc:
Operating System: Windows Architecture: x86_64 (amd64)
Type of failure: Runtime performance bug Test Case: cabal insall H
Blocked By: Blocking:
Related Tickets: #16057 Differential Rev(s):
Wiki Page:

Description

Under Windows 10 using ghc c8.6.3 (Haskell Platform), using cabal to install H (HaskellR) stalls after the message "Completed aeson," with ghc consuming about 5-10% of the CPU forever. I let it run all night and the situation does not change. The command used: 'cabal update; cabal install H'. I tried increasing the priority of the ghc process to "realtime." This increases the cpu usage from 5% to 10-20%, but still no progress after hours (days?).

Change History (2)

comment:1 Changed 9 months ago by RyanGlScott

Resolution: duplicate
Status: newclosed

Thanks for the bug report. I see that the source code of H uses a Template Haskell splice, so this is a almost surely a duplicate of #16057. I'll close this in favor of that ticket.

(Note that this is a regression that was introduced between 8.6.2 and 8.6.3, so one way to work around this is to use 8.6.2.)

Last edited 9 months ago by RyanGlScott (previous) (diff)

comment:2 Changed 9 months ago by dsamperi

It appears that the install process never gets to the source code of H, it stalls after installing aeson, so perhaps the Template Haskell issue comes up in some other package.

Note: See TracTickets for help on using tickets.