Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#1818 closed bug (worksforme)

Code size increase vs. 6.6.1

Reported by: simonmar Owned by:
Priority: high Milestone: 6.8.3
Component: Compiler Version: 6.8.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Runtime performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Code size for 6.8.1 has increased around 20% compared to 6.6.1. Find out why, and fix it. Measurements taken for nofib compiled with -O, libraries compiled with -O2.

Possibly relevant tickets: #1811

Change History (7)

comment:1 Changed 12 years ago by simonmar

Milestone: 6.8.26.8.3

Performance summary for 6.8.2 relative to 6.8.1 and 6.6.1. In all cases, the libraries were compiled with -O2 and the nofib suite was compiled with -O (this is just the default setting, I should probably redo the figures using -O2).

  • 6.8.2 produces binaries 7.5% smaller than 6.8.1, but still 13.5% larger than 6.6.1
  • Allocations are down a bit on average in 6.8.2. Some programs got significantly better (mandel, x2n1), and some got worse, particularly fulsom (+34% allocation +39% runtime), but this just puts it back to where it was with 6.6.1. We should look into this.
  • Performance for nofib is roughly equal for 6.8.2 relative to 6.8.1 (+0.4% runtime)
  • Compile times are down by 4%, but this figure tends to wobble quite a bit.

comment:2 Changed 12 years ago by igloo

Priority: normalhigh

comment:3 Changed 12 years ago by simonmar

Type: bugrun-time performance bug

comment:4 Changed 11 years ago by simonmar

Resolution: worksforme
Status: newclosed

I measured a 5% code size difference between 6.8.2 and 6.8.3, but on recompiling a fresh 6.8.2 tree with exactly the same build options as were used for 6.8.3, the difference disappeared. I suspect something caused by a difference in options, so probably not a 6.6.1->6.8.1 regression, and hence I'll close the bug.

comment:5 Changed 11 years ago by simonmar

Architecture: UnknownUnknown/Multiple

comment:6 Changed 11 years ago by simonmar

Operating System: UnknownUnknown/Multiple

comment:7 Changed 10 years ago by simonmar

Type of failure: Runtime performance bug
Note: See TracTickets for help on using tickets.