Opened 11 years ago

Closed 10 years ago

#2211 closed bug (invalid)

Installing latest GHC-6.8.2 stable: pwd with floating point exception

Reported by: guest Owned by:
Priority: normal Milestone: 6.12 branch
Component: Compiler Version: 6.10.1
Keywords: Floating point exception Cc: ghc@…
Operating System: Linux Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

I tried to install

http://www.haskell.org/ghc/dist/stable/dist/ghc-6.8.2.20080410-i386-unknown-linux.tar.bz2

on Kubuntu. It was reported to be build properly:

http://www.haskell.org/pipermail/cvs-ghc/2008-April/041915.html

but I get:

/tmp/ghc-6.8.2.20080410> ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
Which we'll further canonicalise into: i386-unknown-linux
checking for path to top of build tree... configure: error: cannot determine current directory

From other reports I got to know that this might have to do with the custom 'pwd' of ghc installation. Indeed I get:

/tmp/ghc-6.8.2.20080410> ./utils/pwd/pwd
Floating point exception

Change History (7)

comment:1 Changed 11 years ago by igloo

difficulty: Unknown
Resolution: invalid
Status: newclosed

Thanks for the report. However, this is caused by your system libraries (libc?) being too old for the binaries.

The binary works for me.

comment:2 Changed 11 years ago by spookylukey

I have the same thing, trying to install on CentOS 4.5

This should really be a wontfix, not invalid.

Also, it would be nice to know *before* downloading etc that it isn't going to work. The download page for GHC should at least have a message stating the requirements for the binary.

CentOS 4.5 has glibc 2.3.4, BTW. This may seem ancient, but in lots of shared hosting environments, this kind of thing is typical -- hosts like stability and don't care for the latest versions of everything.

comment:3 Changed 10 years ago by guest

Keywords: Floating point exception added
Resolution: invalid
severity: normalcritical
Status: closedreopened
Version: 6.8.26.10.1

same problem, amd thunderbird 1100MHz, none of the binaries working, error is: Floating point exception

comment:4 Changed 10 years ago by simonmar

This error is caused by an incompatibility between the libc on your system and the one on the system we used to build GHC. Update to a more recent version of the OS and you'll be fine.

Igloo: do we know which version(s) of glibc are ok, so we can document it on the download page?

comment:5 Changed 10 years ago by igloo

I don't know which versions are OK.

comment:6 Changed 10 years ago by igloo

Milestone: 6.12 branch

comment:7 Changed 10 years ago by igloo

Resolution: invalid
Status: reopenedclosed

We don't have a way to keep this info up-to-date, and I think incorrect info would be worse than no info, so I'm closing this ticket.

Note: See TracTickets for help on using tickets.