Opened 11 years ago

Closed 11 years ago

#2375 closed bug (fixed)

RTS assertion failure on Vista with -DEBUG

Reported by: dias Owned by: simonmar
Priority: normal Milestone: 6.10.1
Component: Runtime System Version: 6.8.2
Keywords: rts -DEBUG hashtables memory leak Cc:
Operating System: Windows Architecture: x86
Type of failure: None/Unknown Test Case: ghci/prog002
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The ghci/prog002 test causes an assertion failure when the RTS has been compiled with -DEBUG. Specifically, in Linker.c, the hashtables are not freed by the ocResolve_PEi386 function. It looks like either the assertion in unloadObj is wrong, or there is a memory leak.

Change History (3)

comment:1 Changed 11 years ago by igloo

difficulty: Unknown
Milestone: 6.10.1

Reproducible with a validate build where

GhcDebugged=YES

is in mk/validate.mk:

ghc.exe: internal error: ASSERTION FAILED: file Linker.c, line 1512

    (GHC version 6.9.20080705 for i386_unknown_mingw32)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

comment:2 Changed 11 years ago by simonmar

Owner: set to simonmar

comment:3 Changed 11 years ago by simonmar

Resolution: fixed
Status: newclosed

Fixed:

Wed Jul 30 11:12:52 BST 2008  Simon Marlow <marlowsd@gmail.com>
  * FIX #2375: remove oc->lochash completely, it apparently isn't used
Note: See TracTickets for help on using tickets.