Opened 11 years ago

Closed 11 years ago

#2763 closed bug (duplicate)

while installing cabal from darcs, 1.6.0.1 and 1.4.0.2

Reported by: guest Owned by:
Priority: normal Milestone: 6.10 branch
Component: Compiler Version: 6.8.2
Keywords: cabal ghc ubuntu Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

I can't build cabal 1.4.0.2, cabal from darcs and cabal 1.6.0.1

Running ubuntu 8.04, running ghc that comes with it

root@burn:~/projects/haskell/Cabal-1.4.0.2# ghc -v
Glasgow Haskell Compiler, Version 6.8.2, for Haskell 98, stage 2 booted by GHC version 6.8.2
Using package config file: /usr/lib/ghc-6.8.2/package.conf
Using package config file: /home/abez/.ghc/x86_64-linux-6.8.2/package.conf
hiding package mtl-1.1.0.0 to avoid conflict with later version mtl-1.1.0.1
wired-in package base mapped to base-3.0.1.0
wired-in package rts mapped to rts-1.0
wired-in package haskell98 mapped to haskell98-1.0.1.0
wired-in package template-haskell mapped to template-haskell-2.2.0.0
wired-in package ndp not found.
Hsc static flags: -static
*** Deleting temp files:
Deleting: 
*** Deleting temp dirs:
Deleting: 
ghc-6.8.2: no input files
Usage: For basic information, try the `--help' option.
root@burn:~/projects/haskell/Cabal-1.4.0.2# ghc -v
Glasgow Haskell Compiler, Version 6.8.2, for Haskell 98, stage 2 booted by GHC version 6.8.2
Using package config file: /usr/lib/ghc-6.8.2/package.conf
Using package config file: /home/abez/.ghc/x86_64-linux-6.8.2/package.conf
hiding package mtl-1.1.0.0 to avoid conflict with later version mtl-1.1.0.1
wired-in package base mapped to base-3.0.1.0
wired-in package rts mapped to rts-1.0
wired-in package haskell98 mapped to haskell98-1.0.1.0
wired-in package template-haskell mapped to template-haskell-2.2.0.0
wired-in package ndp not found.
Hsc static flags: -static
*** Deleting temp files:
Deleting: 
*** Deleting temp dirs:
Deleting: 
ghc-6.8.2: no input files
Usage: For basic information, try the `--help' option.
root@burn:~/projects/haskell/Cabal-1.4.0.2# uname -a
Linux burn 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux
root@burn:~/projects/haskell/Cabal-1.4.0.2#     ./Setup build
Preprocessing library Cabal-1.4.0.2...
Building Cabal-1.4.0.2...
[13 of 45] Compiling Distribution.Simple.Utils ( Distribution/Simple/Utils.hs, dist/build/Distribution/Simple/Utils.o )
ghc-6.8.2: panic! (the 'impossible' happened)
  (GHC version 6.8.2 for x86_64-unknown-linux):
	applyTypeToArgs
    unix-2.3.0.0:System.Posix.Signals.a38{v rBu} [gid]
      (unix-2.3.0.0:System.Posix.Signals.a5{v rBt} [gid]
       `cast` (base:GHC.Prim.sym{(w) tc 34v}
                 (base:Foreign.C.Types.:CoCInt{tc ryy})
               :: <pred>base:GHC.Int.Int32{tc 3V}
                          ~
                        <nt>base:Foreign.C.Types.CInt{tc rz9}))
      unix-2.3.0.0:System.Posix.Signals.Ignore{v rBs} [gid]
      (base:Data.Maybe.Nothing{v r6a} [gid]
         @ <nt>unix-2.3.0.0:System.Posix.Signals.SignalSet{tc rBr})
      eta{v a2Rl} [lid]
    (# base:GHC.Prim.State#{(w) tc 32q}
         base:GHC.Prim.RealWorld{(w) tc 31E},
       <nt>unix-2.3.0.0:System.Posix.Signals.SignalSet{tc rBr} #)

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Another one:

@burn:~/projects/haskell/cabal$     ./Setup build
Preprocessing library Cabal-1.6.0.1...
Building Cabal-1.6.0.1...
[ 1 of 50] Compiling Distribution.Simple.GHC.Makefile ( Distribution/Simple/GHC/Makefile.hs, dist/build/Distribution/Simple/GHC/Makefile.o )
[ 2 of 50] Compiling Distribution.Compat.Permissions ( Distribution/Compat/Permissions.hs, dist/build/Distribution/Compat/Permissions.o )
[ 3 of 50] Compiling Distribution.Compat.Exception ( Distribution/Compat/Exception.hs, dist/build/Distribution/Compat/Exception.o )
[ 4 of 50] Compiling Distribution.Compat.TempFile ( Distribution/Compat/TempFile.hs, dist/build/Distribution/Compat/TempFile.o )
[ 5 of 50] Compiling Distribution.GetOpt ( Distribution/GetOpt.hs, dist/build/Distribution/GetOpt.o )
[ 6 of 50] Compiling Distribution.Compat.ReadP ( Distribution/Compat/ReadP.hs, dist/build/Distribution/Compat/ReadP.o )
[ 7 of 50] Compiling Distribution.Text ( Distribution/Text.hs, dist/build/Distribution/Text.o )
[ 8 of 50] Compiling Distribution.Version ( Distribution/Version.hs, dist/build/Distribution/Version.o )
[ 9 of 50] Compiling Language.Haskell.Extension ( Language/Haskell/Extension.hs, dist/build/Language/Haskell/Extension.o )
[10 of 50] Compiling Distribution.System ( Distribution/System.hs, dist/build/Distribution/System.o )
[11 of 50] Compiling Distribution.Simple.PreProcess.Unlit ( Distribution/Simple/PreProcess/Unlit.hs, dist/build/Distribution/Simple/PreProcess/Unlit.o )
[12 of 50] Compiling Distribution.ReadE ( Distribution/ReadE.hs, dist/build/Distribution/ReadE.o )
[13 of 50] Compiling Distribution.Verbosity ( Distribution/Verbosity.hs, dist/build/Distribution/Verbosity.o )
[14 of 50] Compiling Distribution.Package ( Distribution/Package.hs, dist/build/Distribution/Package.o )
[15 of 50] Compiling Distribution.ModuleName ( Distribution/ModuleName.hs, dist/build/Distribution/ModuleName.o )
[16 of 50] Compiling Distribution.Simple.Utils ( Distribution/Simple/Utils.hs, dist/build/Distribution/Simple/Utils.o )
ghc-6.8.2: panic! (the 'impossible' happened)
  (GHC version 6.8.2 for x86_64-unknown-linux):
	applyTypeToArgs
    unix-2.3.0.0:System.Posix.Signals.a38{v roIc} [gid]
      (unix-2.3.0.0:System.Posix.Signals.a5{v roIb} [gid]
       `cast` (base:GHC.Prim.sym{(w) tc 34v}
                 (base:Foreign.C.Types.:CoCInt{tc r1dN})
               :: <pred>base:GHC.Int.Int32{tc 3V}
                          ~
                        <nt>base:Foreign.C.Types.CInt{tc r17X}))
      unix-2.3.0.0:System.Posix.Signals.Ignore{v roIa} [gid]
      (base:Data.Maybe.Nothing{v r6E} [gid]
         @ <nt>unix-2.3.0.0:System.Posix.Signals.SignalSet{tc roI9})
      eta{v apPk} [lid]
    (# base:GHC.Prim.State#{(w) tc 32q}
         base:GHC.Prim.RealWorld{(w) tc 31E},
       <nt>unix-2.3.0.0:System.Posix.Signals.SignalSet{tc roI9} #)

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (4)

comment:1 Changed 11 years ago by igloo

Description: modified (diff)
difficulty: Unknown

comment:2 Changed 11 years ago by igloo

Milestone: 6.10 branch

I can't reproduce this. I don't know what the error means OTTOMH, so I'll leave it open for now, but my suspicion is that the problem is that a library upgrade left another library in a broken state or something.

comment:3 Changed 11 years ago by simonpj

cf #3060, which has similar symptoms (and lack of them).

S

comment:4 Changed 11 years ago by simonmar

Resolution: duplicate
Status: newclosed

Probably the same as #3060, which has more background.

Note: See TracTickets for help on using tickets.