Opened 10 years ago

Closed 10 years ago

#3422 closed bug (duplicate)

No match in record selector Var.tcTyVarDetails

Reported by: guest Owned by: chak
Priority: normal Milestone:
Component: Compiler Version: 6.10.4
Keywords: deriving instance, type family Cc:
Operating System: Linux Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

See http://hpaste.org/fastcgi/hpaste.fcgi/view?id=7993#a7993

This also happens on ghc 6.10.4

KiYungAhn

Change History (4)

comment:1 Changed 10 years ago by chak

Owner: set to chak
{-# OPTIONS_GHC -fglasgow-exts #-}
{-# LANGUAGE UndecidableInstances #-}

module GHCBug where

newtype Trie m k a = Trie (Maybe a, m (SubKey k) (Trie m k a))

type family SubKey k
type instance SubKey [k] = k

deriving instance (Eq (m k (Trie m [k] a))
                  ,Eq a) => Eq (Trie m [k] a)

{-
[m@monire ~]$ ghc -O2 -c --make GHCBug.hs
[1 of 1] Compiling GHCBug           ( GHCBug.hs, GHCBug.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.3 for x86_64-unknown-linux):
  No match in record selector Var.tcTyVarDetails

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
-}

comment:2 Changed 10 years ago by chak

Happens in the HEAD, too.

comment:3 Changed 10 years ago by chak

Duplicate of #3423

comment:4 Changed 10 years ago by chak

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.