Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#3471 closed bug (duplicate)

configure fails for GHC 6.10.4 on Mac OS X 10.6 in 64-bit mode with previously-built GHC

Reported by: paulrbrown Owned by:
Priority: normal Milestone:
Component: Build System (make) Version: 6.10.4
Keywords: configure Cc:
Operating System: Unknown/Multiple Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The environment is a Mac with 10.6 running in 64-bit mode but with a ghc that was built under 10.5.

Running configure produces the following output:

$ ./configure --prefix=/Users/prb/opt/localchecking build system type... i386-apple-darwin10.0.0
checking host system type... i386-apple-darwin10.0.0
checking target system type... i386-apple-darwin10.0.0
Canonicalised to: i386-apple-darwin
checking for ghc... /Users/prb/opt/local/bin/ghc
checking version of ghc... 6.10.1
checking for nhc... no
checking for nhc98... no
checking for hbc... no
checking for ld... /usr/bin/ld
checking for path to top of build tree... 
/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:144:0:
    suffix or operands invalid for `push'

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:189:0:
    suffix or operands invalid for `push'

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:892:0:
    suffix or operands invalid for `push'

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:941:0:
    suffix or operands invalid for `push'

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:967:0:
    32-bit absolute addressing is not supported for x86-64

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:967:0:
    cannot do signed 4 byte relocation

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:970:0:
    32-bit absolute addressing is not supported for x86-64

/var/folders/V+/V+RuS+kKF50QvE4Dmj4MPE+++TI/-Tmp-/ghc19350_0/ghc19350_0.s:970:0:
    cannot do signed 4 byte relocation
./configure: line 3211: utils/pwd/pwd: No such file or directory
configure: error: cannot determine current directory

Changing this to the usual pwd commands makes the configure run complete, but make fails immediately with a similar trace.

Attachments (1)

ghc-6.10.4 (213 bytes) - added by chak 10 years ago.
/usr/bin/ghc — shell script invoking the compiler

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by paulrbrown

Seems related to #3400

comment:2 Changed 10 years ago by chak

Resolution: duplicate
Status: newclosed

This is not a problem with the GHC you are trying to build, but with the ghc from 10.5 that you try to use for bootstrapping.

To use a GHC built on 10.5 on 10.6, you need to edit /usr/bin/ghc and add the flags -optc-m32 -opta-m32 -optl-m32. I attach the edited /usr/bin/ghc for GHC 6.10.4 if you just want to copy that.

I'll close this ticket as it's a duplicate of #3400.

Changed 10 years ago by chak

Attachment: ghc-6.10.4 added

/usr/bin/ghc — shell script invoking the compiler

comment:3 Changed 12 months ago by bgamari

Component: Build SystemBuild System (make)

The new Hadrian build system has been merged. Relabeling the tickets concerning the legacy make build system to prevent confusion.

Note: See TracTickets for help on using tickets.