Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#3768 closed bug (fixed)

6.12.1 Mac OS X installer lacks all HTML documentation

Reported by: Minimiscience Owned by:
Priority: normal Milestone: 6.12.2
Component: Documentation Version: 6.12.1
Keywords: Cc:
Operating System: MacOS X Architecture: x86
Type of failure: Documentation bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

After upgrading GHC from 6.10.4 to 6.12.1 using the installer package for Mac OS X Leopard, I found that the local HTML documentation (aside from moving from /usr/share/doc/ghc/index.html to /usr/share/doc/ghc/html/index.html) was lacking a few parts. Specifically, the links to the user's guide, GHC API, and Cabal no longer lead to extant documents, and I was unable to find the documents that they should link to anywhere in the /Library/Frameworks/GHC.framework/Versions directory. The only local link that still works is the link to the library documentation, and its index page still lists some modules that are no longer distributed with the current version of GHC (specifically, the mtl package, though there may be others that I haven't come across).

This was observed on Mac OS X 10.5.8 with gcc 4.0.1, though it may or may not also apply to other systems.

Change History (5)

comment:1 Changed 10 years ago by igloo

Milestone: 6.12.2
Owner: set to igloo

Thanks for the report; I'll take a look.

comment:2 Changed 10 years ago by igloo

OK, the problem is that my Mac doesn't have the right docbook things installed, or they aren't installed in the right places. I've prodded it a bit, but got nowhere. If anyone knows how to fix this on OS X, please let me know:

checking for xmllint... /usr/bin/xmllint
checking for DocBook DTD... I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd
conftest.xml:5: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
[...]
failed
configure: WARNING: cannot find a DTD for DocBook XML V4.2, you will not be able to validate your documentation
configure: WARNING: check your XML_CATALOG_FILES environment variable and/or /etc/xml/catalog
checking for xsltproc... /usr/bin/xsltproc
checking for DocBook XSL stylesheet... no
configure: WARNING: cannot find DocBook XSL stylesheets, you will not be able to build the documentation

comment:3 Changed 10 years ago by igloo

Owner: igloo deleted

comment:4 Changed 9 years ago by igloo

Resolution: fixed
Status: newclosed

I've fixed this now; some notes in case it comes up again:

Install likely-looking packages with MacPorts ("port list", "port install ...").

Some packages needed XCode 3.1, which for OS X 10.5 you can currently only get bundled with the iphone SDK as far as I can tell.

Then, to fix:

$ "/opt/local/bin/dblatex"  docs/users_guide/users_guide.xml --ps -o docs/users_guide/users_guide.ps
Traceback (most recent call last):
  File "/opt/local/bin/dblatex", line 16, in <module>
    from dbtexmf.dblatex import dblatex
ImportError: No module named dbtexmf.dblatex

do:

sudo port install python_select
sudo python_select python26

comment:5 Changed 9 years ago by simonmar

Added this info to Building/MacOSX.

Note: See TracTickets for help on using tickets.