Opened 10 years ago

Closed 10 years ago

#3824 closed bug (duplicate)

parse error on gadt pragma

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.4
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

I have a file "zap.hs" containing the single line

{-# LANGUAGE: GADTs #-}

trying to load it into ghci or runhaskell zap.hs results in:

ghc: panic! (the 'impossible' happened)

(GHC version 6.10.4 for x86_64-unknown-linux):

getOptions'.parseLanguage(2) went past eof token

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

Attachments (1)

zap.hs (24 bytes) - added by guest 10 years ago.
file reproducing the problem

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by guest

Attachment: zap.hs added

file reproducing the problem

comment:1 Changed 10 years ago by simonmar

Resolution: duplicate
Status: newclosed

Thanks for the report. This is a duplicate of #3153, fixed in 6.12.1 (you need to remove the ':' from 'LANGUAGE:').

Note: See TracTickets for help on using tickets.