Opened 10 years ago

Closed 10 years ago

#3926 closed bug (duplicate)

STM-based program not terminating

Reported by: mlesniak Owned by:
Priority: normal Milestone:
Component: Runtime System Version: 6.13
Keywords: STM Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The attached program does sometimes not halt, even after the final statement of the main-function is executed. A similar bug has been discussed on the ghc-haskell-users mailing list[1]. The mentioned workaround does not seem to work here.

Tested with the latest GHC HEAD built 6.13.20100316

Documentation for compiling the code is in the source file.

Cheers,

Michael

[1] http://www.haskell.org/pipermail/glasgow-haskell-users/2010-March/018565.html

Attachments (1)

Pi.hs (7.8 KB) - added by mlesniak 10 years ago.
Example code that shows (sometimes) the non-termination

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by mlesniak

Attachment: Pi.hs added

Example code that shows (sometimes) the non-termination

comment:1 Changed 10 years ago by simonmar

Resolution: duplicate
Status: newclosed

I'm sure the cause of this one is #2401, so closing as duplicate.

The workaround to not use unsafeIOToSTM, or at least to not call into the IO library from inside an STM transaction.

Note: See TracTickets for help on using tickets.