Opened 10 years ago

Closed 9 years ago

#4165 closed bug (fixed)

broken links in Cabal docs

Reported by: simonmar Owned by:
Priority: normal Milestone: 7.2.1
Component: Documentation Version: 6.12.3
Keywords: Cc: JoshBBall@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Documentation bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

e.g. http://darcs.haskell.org/download/docs/6.12.3/html/Cabal/authors.html#general-fields, the link for License is broken (looks like it is supposed to point to the library docs).

Change History (4)

comment:1 Changed 9 years ago by igloo

Milestone: 7.0.17.0.2

comment:2 Changed 9 years ago by sciolizer

Cc: JoshBBall@… added

I have submitted a correction for the greencard link to cabal-dev@….

The five remaining broken links are all Cabal links, and the problem is that they don't include the version of Cabal in the link. For instance, the documentation points to

http://darcs.haskell.org/download/docs/6.12.3/html/libraries/Cabal/Distribution-License.html

but the latest documentation is at

http://darcs.haskell.org/download/docs/6.12.3/html/libraries/Cabal-1.8.0.6/Distribution-License.html

I think it would be nice if we didn't have to put version dependent hyperlinks into the documentation. Is there a way to make Cabal redirect to Cabal-1.8.0.6 (or whatever the latest is)?

comment:3 Changed 9 years ago by igloo

Milestone: 7.0.27.2.1

comment:4 Changed 9 years ago by igloo

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.